yum update で ImageMagick がエラーになったので対応した

Laravel

CentOS 6.6 の yum update でこんなエラーが発生した。

エラー: パッケージ: ImageMagick-last-libs-6.9.1.2-1.el6.remi.1.x86_64 (remi)
             要求: libwebp.so.5()(64bit)

以下で対応

$ sudo yum remove ImageMagick-last-libs libwebp
# epel から libwebpをインストール(--enablerepo=remiはつけない)
$ sudo yum install libwebp
$ sudo yum install ImageMagick-last-libs --enablerepo=remi

remiからインストールされていたlibwebpが原因だったらしい。 remi 側でのバージョンの整合性がとれていない?

最終更新日: 2015-4-27

Pocket

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です


*